Internet Assigned Numbers Authority • Domains • Protocols • Numbers • About Simple Mail Transfer Protocol (SMTP) Last Updated 2025-09-19 Note This registry group was formerly known as "MAIL Parameters." Associated Registries [Message Headers] Available Formats [IMG] XML [IMG] HTML [IMG] TXT Registries Included Below • SMTP Service Extensions • SMTP Service Extension Parameters • Mail Transmission Types for the "Received:" Header Field • VIA Link Types • WITH Protocol Types • Additional Registered 'Received:' Clauses • Address Literal Tags • SMTP PRIORITY Extension Priority Assignment Policy • Registered-states • Multicast Email SMTP Extensions • SMTP Server Limits • Mail Header Confidentiality Policies SMTP Service Extensions Registration Procedure(s) Either Model 1 (IETF) or Model 2 (FCFS) as described in [Section 8.1.1.1 of RFC-ietf-emailcore-rfc5321bis-43]. Reference [RFC-ietf-emailcore-rfc5321bis-43, Section 8.1.1, 2.2.2] Note The Simple Mail Transfer Protocol [RFC-ietf-emailcore-rfc5321bis-43] specifies a set of commands or services and a general procedure for extending that set. The table below lists SMTP service extensions. Both message submission [RFC 6409]and mail transfer [RFC-ietf-emailcore-rfc5321bis-43] may use these extensions unless otherwise specified. Note The SMTP Extension names/keywords registered in this section are for general use. For those specific to Multicast email, see the registry for that protocol below. Available Formats [IMG] CSV MAIL/RCPT Message EHLO Keyword Description Reference EHLO Parameters Additional Parameter RegMethod Submission Length Note Contact Change Verbs Values Use and Added Controller Values The description of SEND was SEND Send to terminal [RFC 821] None [RFC 821] [RFC 821] IETF MUST NOT updated by [RFC 1123] and then its IETF IETF actual use was deprecated in [RFC 2821] The description of SOML was SOML Send as mail or to terminal [RFC 821] None [RFC 821] [RFC 821] IETF MUST NOT updated by [RFC 1123] and then its IETF IETF actual use was deprecated in [RFC 2821] The description of SAML was SAML Send as mail and to terminal [RFC 821] None [RFC 821] [RFC 821] IETF MUST NOT updated by [RFC 1123] and then its IETF IETF actual use was deprecated in [RFC 2821] Implementation support for VRFY is required in servers, but its VRFY VRFY command as specified in [RFC-ietf-emailcore-rfc5321bis-43] None None None IETF MUST NOT 0 listing in the EHLO response is IETF IETF [RFC-ietf-emailcore-rfc5321bis-43] optional. See [Section 3.5.2 of RFC-ietf-emailcore-rfc5321bis-43] for details on this subject. EXPN Expand the mailing list [RFC 821] None [RFC 821] [RFC 821] IETF MUST NOT Command description updated by IETF IETF [RFC-ietf-emailcore-rfc5321bis-43] HELP Supply helpful information [RFC 821] None [RFC 821] [RFC 821] IETF MUST NOT Command description updated by IETF IETF [RFC-ietf-emailcore-rfc5321bis-43] TURN Interchange the client and server [RFC 821] None [RFC 821] [RFC 821] IETF MUST NOT The actual use of TURN was IETF IETF roles deprecated in [RFC 2821] 8BITMIME SMTP and Submit transport of 8bit [RFC 6152] None [RFC 6152] [RFC IETF SHOULD IETF IETF MIME content 6152] For additional declarations or SIZE Message size declaration [RFC 1870] number [RFC 1870] [RFC IETF MAY limits of this general type, see IETF IETF 1870] the LIMITS extension below and the SMTP Server Limits registry. VERB Verbose [Eric Allman] Not supplied Not Not Legacy Not Not Eric Eric supplied supplied supplied supplied Allman Allman ONEX One message transaction only [Eric Allman] Not supplied Not Not Legacy Not Not Eric Eric supplied supplied supplied supplied Allman Allman CHUNKING Chunking [RFC 3030] None [RFC 3030] [RFC IETF MAY IETF IETF 3030] BINARYMIME Binary MIME [RFC 3030] None [RFC 3030] [RFC IETF MAY IETF IETF 3030] CHECKPOINT Checkpoint/Restart [RFC 1845] None [RFC 1845] [RFC IETF MAY IETF IETF 1845] DELIVERBY Deliver By [RFC 2852] None [RFC 2852] [RFC IETF MAY IETF IETF 2852] PIPELINING Command Pipelining [RFC 2920] None [RFC 2920] [RFC IETF SHOULD IETF IETF 2920] DSN Delivery Status Notification [RFC 3461] None [RFC 3461] [RFC IETF SHOULD IETF IETF 3461] SMTP ETRN Extended Turn [RFC 1985] None [RFC 1985] [RFC IETF MUST NOT [RFC-ietf-emailcore-rfc5321bis-43] IETF IETF 1985] only. Not for use on Submit port 587. ENHANCEDSTATUSCODES Enhanced Status Codes [RFC 2034] None [RFC 2034] [RFC IETF SHOULD IETF IETF 2034] STARTTLS Start TLS [RFC 3207] None [RFC 3207] [RFC IETF MAY IETF IETF 3207] NO-SOLICITING Notification of no soliciting [RFC 3865] Soliciting-keywords [RFC 3865] [RFC IETF MAY IETF IETF 3865] MTRK Message Tracking [RFC 3885] [RFC 3885] [RFC IETF MAY IETF IETF 3885] [RFC Deprecated by [Moving RFC 4405, SUBMITTER SMTP Responsible Submitter [RFC 4405] None [RFC 4405] 4405] IETF MUST NOT RFC 4406, RFC 4407 (Sender-ID) to IETF IETF Historic]. SMTP ATRN Authenticated TURN [RFC 2645] None [RFC 2645] [RFC IETF MUST NOT [RFC-ietf-emailcore-rfc5321bis-43] IETF IETF 2645] only. Not for use on Submit port 587. AUTH Authentication [RFC 4954] SASL mechanism [RFC 4954] [RFC IETF MUST IETF IETF names 4954] BURL Remote Content [RFC 4468] Permitted URL [RFC 4468] [RFC IETF MUST NOT Submit [RFC 6409] only. Not for IETF IETF prefixes 4468] use with SMTP on port 25. FUTURERELEASE Future Message Release [RFC 4865] None [RFC 4865] [RFC IETF MUST NOT IETF IETF 4865] UTF8SMTP Internationalized email address [RFC 5336] None [RFC 5336] [RFC IETF MUST NOT Experimental; deprecated in [RFC IETF IETF 5336] 6531]. CONPERM Content Conversion Permission [RFC 4141] None [RFC 4141] [RFC IETF MAY IETF IETF 4141] CONNEG Content Conversion Negotiation [RFC 4141] None [RFC 4141] [RFC IETF MAY IETF IETF 4141] SMTPUTF8 Internationalized email address [RFC 6531] None [RFC 6531] [RFC IETF MUST NOT IETF IETF 6531] Name of the [RFC MT-PRIORITY Priority Message Handling [RFC 6710] Priority Assignment [RFC 6710] 6710] IETF MUST NOT IETF IETF Policy (optional) RRVS Require Recipient Valid Since [RFC 7293] None [RFC 7293] [RFC IETF MUST NOT IETF IETF 7293] REQUIRETLS Require TLS [RFC 8689] None [RFC 8689] [RFC IETF MUST NOT IETF IETF 8689] LIMITS Server limits [RFC 9422] None [RFC 9422] [RFC IETF MUST NOT See "SMTP Server Limits" registry. IETF IETF 9422] SMTP Service Extension Parameters Registration Procedure(s) Registry closed Reference [RFC-ietf-emailcore-rfc5321bis-43] Note These entries have been incorporated into the SMTP Service Extension registry's "EHLO Parameters" field. Mail Transmission Types for the "Received:" Header Field Reference [RFC-ietf-emailcore-rfc5321bis-43, Section 8.1.3, 8.1.4][RFC-ietf-emailcore-rfc5322bis-12] Note The Simple Mail Transfer Protocol [RFC-ietf-emailcore-rfc5321bis-43] and the Standard for Internet Message Formats [RFC-ietf-emailcore-rfc5322bis-12] specify that a set of "Received" lines will be prepended to the headers of electronic mail messages as they are transported through the Internet. These received line may optionally include either or both a "via" phrase and/or a "with" phrase. The legal values for the phrases are listed here. The via phrase is intended to indicate the link or physical medium over which the message was transferred. The with phrase is intended to indicate the protocol or logical process that was used to transfer the message. VIA Link Types Registration Procedure(s) RFC Required Reference [RFC-ietf-emailcore-rfc5321bis-43] Available Formats [IMG] CSV VIA link types Description Reference UUCP Unix-to-Unix Copy Program TCP TCP [RFC-ietf-emailcore-rfc5321bis-43] WITH Protocol Types Registration Procedure(s) RFC Required Reference [RFC-ietf-emailcore-rfc5321bis-43] Available Formats [IMG] CSV WITH protocol types Description Reference SMTP Simple Mail Transfer Protocol [RFC-ietf-emailcore-rfc5321bis-43] ESMTP SMTP with Service Extensions [RFC-ietf-emailcore-rfc5321bis-43] ESMTPA ESMTP with AUTH [RFC 3848] ESMTPS ESMTP with STARTTLS [RFC 3848] ESMTPSA ESMTP with both STARTTLS and AUTH [RFC 3848] LMTP Local Mail Transfer Protocol [RFC 3848] LMTPA LMTP with AUTH [RFC 3848] LMTPS LMTP with STARTTLS [RFC 3848] LMTPSA LMTP with both STARTTLS and AUTH [RFC 3848] MMS Multimedia Messaging Service [RFC 4356] UTF8SMTP ESMTP with SMTPUTF8 [RFC 6531] UTF8SMTPA ESMTP with SMTPUTF8 and AUTH [RFC 4954]; [RFC 6531] UTF8SMTPS ESMTP with SMTPUTF8 and STARTTLS [RFC 3207]; [RFC 6531] UTF8SMTPSA ESMTP with SMTPUTF8 and both STARTTLS and AUTH [RFC 3207]; [RFC 4954]; [RFC 6531] UTF8LMTP LMTP with SMTPUTF8 [RFC 6531] UTF8LMTPA LMTP with SMTPUTF8 and AUTH [RFC 4954]; [RFC 6531] UTF8LMTPS LMTP with SMTPUTF8 and STARTTLS [RFC 3207]; [RFC 6531] UTF8LMTPSA LMTP with SMTPUTF8 and both STARTTLS and AUTH [RFC 3207]; [RFC 4954]; [RFC 6531] Additional Registered 'Received:' Clauses Registration Procedure(s) IETF Review Reference [RFC-ietf-emailcore-rfc5321bis-43] Available Formats [IMG] CSV Clause Name Service Extension Description Syntax Summary Reference PRIORITY Records the value of the MT-PRIORITY parameter specified in See Section 7 of RFC [RFC 6710] [RFC 6710] the MAIL FROM command state Indicates entry into a special queue state state [RFC 6729] tls-cipher = tls-cipher-name / tls-cipher-hex tls-cipher-name = ALPHA *(ALPHA / DIGIT / "_") tls Indicates the TLS cipher used ; as registered in the IANA TLS Cipher Suite [RFC 8314] Registry tls-cipher-hex = "0x" 4HEXDIG Indicates the Diffie-Hellman group used with the TLS cipher dh-group = ALPHA *(ALPHA / DIGIT / "_" / "-") group (if applicable) ; as registered in the IANA TLS Supported Groups [RFC 8314] Registry Address Literal Tags Registration Procedure(s) Standards Action Reference [RFC-ietf-emailcore-rfc5321bis-43] Note Sometimes a host is not known to the domain name system and communication (and, in particular, communication to report and repair the error) is blocked. To bypass this barrier a special literal form of the address is allowed as an alternative to a domain name. For IPv4 addresses, this form uses four small decimal integers separated by dots and enclosed by brackets such as [123.255.37.2], which indicates an (IPv4) Internet Address in sequence-of-octets form. For IPv6 and other forms of addressing that might eventually be standardized, the form consists of a standardized "tag" that identifies the address syntax, a colon, and the address itself, in a format specified as part of the IPv6 standards [RFC 5952]. Available Formats [IMG] CSV Tag Reference IPv6 [RFC-ietf-emailcore-rfc5321bis-43] SMTP PRIORITY Extension Priority Assignment Policy Registration Procedure(s) Specification Required Expert(s) Unassigned Reference [RFC 6710] Available Formats [IMG] CSV Policy Name Comment Reference MIXER Default policy [RFC 6710, Appendix B] STANAG4406 [RFC 6710, Appendix A] NSEP [RFC 6710, Appendix C] Registered-states Registration Procedure(s) First Come First Served Reference [RFC 6729] Available Formats [IMG] CSV Name Description Reference Use auth Held for message authentication [RFC 6729] current content Held for message content analysis [RFC 6729] current convert Held for message content conversion [RFC 6729] current moderation Held for list moderation [RFC 6729] current normal Message is not being held other than to accommodate typical relaying handling [RFC 6729] current other Held for causes not covered by other registered state keywords [RFC 6729] current outbound Message placed in outbound queue [RFC 6729] current quarantine Held for operator action due to content analysis or local policy [RFC 6729] current timed Held to accommodate a specific requested delivery window [RFC 6729] current Multicast Email SMTP Extensions Registration Procedure(s) Specification Required Expert(s) Alexey Melnikov (primary), RFC Independent Submissions Editor (secondary) Reference [RFC 8494] Note Extension names/keywords and status used with Multicast Email; see SMTP Service Extensions above for the list for more general use. Available Formats [IMG] CSV Name Status Multicast-Mail-Specific References Non-Multicast-Specific References Note SIZE Required [RFC 1870] 8BITMIME Required [RFC 6152] DSN Required [RFC 3461] MT-PRIORITY Required [RFC 6710] DELIVERBY Required [RFC 2852] BINARYMIME Required [RFC 3030] SMTP CHUNKING MUST be supported on the receiving SMTP side of an SMTP-to-MULE gateway and MAY be CHUNKING Special [RFC 3030] used on the sending side of a MULE-to-SMTP gateway. A MULE relay doesn't need to do anything special for this extension. The ENHANCEDSTATUSCODES extension is supported by ENHANCEDSTATUSCODES Special [RFC 2034] including relevant status codes in DSN [RFC 3461] reports. RRVS Supported [RFC 7293] SUBMITTER Supported [RFC 4405] Deprecated by [Moving RFC 4405, RFC 4406, RFC 4407 (Sender-ID) to Historic]. PIPELINING N/A [RFC 2920] STARTTLS N/A [RFC 3207] The AUTH parameter to the MAIL FROM command is AUTH Special [RFC 4954] "Supported", but the rest of the AUTH extension is not applicable to MULE. BURL N/A [RFC 4468] NO-SOLICITING N/A [RFC 3865] CHECKPOINT Disallowed [RFC 1845] CONNEG Disallowed [RFC 4141] SMTP Server Limits Registration Procedure(s) Specification Required Expert(s) John Klensin, Murray Kucherawy (backup) Reference [RFC 9422] Available Formats [IMG] CSV Name Value syntax Description Restrictions Security Considerations Reference MAILMAX specifies the maximum number of transactions (MAIL MAILMAX %x31-39 0*5DIGIT ; "0" not FROM commands) the server will accept in a single session. None See [RFC 9422, Section 6] [RFC 9422] allowed, six-digit maximum The count includes all MAIL FROM commands, regardless of whether they succeed or fail. RCPTMAX specifies the maximum number of RCPT TO commands %x31-39 0*5DIGIT ; "0" not the server will accept in a single transaction. It is not a RCPTMAX allowed, six-digit maximum limit on the actual number of recipients the message ends None See [RFC 9422, Section 6] [RFC 9422] up being sent to; a single RCPT TO command may produce multiple recipients or, in the event of an error, none. RCPTDOMAINMAX specifies the maximum number of different %x31-39 0*5DIGIT ; "0" not domains that can appear in a recipient (RCPT TO) address RCPTDOMAINMAX allowed, six-digit maximum within a single session. This limit is imposed by some None See [RFC 9422, Section 6] [RFC 9422] servers that bind to a specific internal delivery mechanism on receipt of the first RCPT TO command. Mail Header Confidentiality Policies Registration Procedure(s) Specification Required or IETF Review (see Note) Expert(s) Daniel Kahn Gillmor (primary), Bernie Hoeneisen (secondary) Reference [RFC 9788] Note Adding an entry to this registry with an N in the "Recommended" column follows the registration policy of Specification Required. Adding an entry to this registry with a Y in the "Recommended" column or changing the "Recommended" column in an existing entry (from N to Y or vice versa) requires IETF Review. Note The Header Confidentiality Policy Name never appears on the wire. This registry merely tracks stable references to implementable descriptions of distinct policies. Any addition to this registry should be governed by guidance in [Section 3.4.2 of RFC 9788]. Available Formats [IMG] CSV Header Confidentiality Policy Name Description Recommended Reference hcp_no_confidentiality No header confidentiality N [RFC 9788, Section 3.2.3] hcp_baseline Confidentiality for Informational Header Fields: Subject Header Field is Y [RFC 9788, Section 3.2.1] obscured, Keywords and Comments are removed hcp_shy Obscure Subject, remove Keywords and Comments, remove the time zone from N [RFC 9788, Section 3.2.2] Date, and remove display-names from From, To, and Cc Licensing Terms